Monday, October 3, 2011

[Tech Tip] Google Chrome Won't Launch

I cannot tell you how I lived without my favorite web browser for past one week. I searched everywhere on the internet (using the crappy old monolithic Internet Explorer) for fixes to why Chrome (or FireFox for that matter) would show up in Task Manager, but won't launch.

Now that I know why, I will share it with you:

If multiple AntiVirus/AntiSpamware scans yield to nothing, and you recently did not allow a Microsoft update, most likely spoolsv.exe service is to blame. In my case, that is what was the issue.

Apparently Chrome (and surprisingly Firefox too) rely on spoolsv.exe service to tell them about the available printers at launch time. Now if the spooler cannot respond in time, it looks like the querying programs hung up indefinitely, even before displaying any GUI.

Try killing spoolsv.exe manually in task manager, and launch Chrome again. If it does, good for you - don't forget to put a thank you note below. If it doesn't, well, you may have found another issue, solve it to your own piece of fame:-)

Good luck!

P.S. It is amazing how annoying such issues can be, with the user left with no objective data as to what is going wrong. Google, and the mighty dumbed down Microsoft, take a note please?

7 comments:

  1. I tried what you said and it didnt work :( however, when i keep pressing the icon, it does open for a second before closing again. I think i may have downloaded a virus or something. Any advice? thanks

    ReplyDelete
  2. I came to this same conclusion as you. Another symptom is the 'Printers' in Control Panel would hang as well. Also, both browsers would lunch when windows is in safe mode. How frustrating that no feedback or hint to help track this down.

    I ended up clearing the printer spool folder in windows and now spooler works normal. See: http://www.sevenforums.com/tutorials/89483-print-spooler-queue-clear-reset.html

    Thanks for posting this, even though I found it a little too late.

    ReplyDelete
  3. Worked for me... Many thanks.... maybe... wondering if its going to cause me any other problems elswhere.

    ReplyDelete
  4. Worked for me. Thanks a lot!

    ReplyDelete
  5. I tried doing that and a window popped up saying "Request could not be completed, Access is denied" : (

    ReplyDelete
  6. Having the same issue since a windows update last week and no reply from google chrome help team 5 days on.

    ReplyDelete
  7. For instance, with Google, Blue Widget and Widget Blue are dealt with the same way. Not so with Yahoo! furthermore, Live, they are dealt with as totally distinctive search queries. https://800support.net/google-latest-news/google-trips-app/

    ReplyDelete

Thank you for leaving a comment on my blog. Please feel free to share any information you find relevant here.